12. Drucklayouts bearbeiten

12. Drucklayouts bearbeiten und anpassen

In allen Versionen von gFM-Business können alle Drucklayouts beliebig angepaßt werden. Um ein Drucklayout anzupassen, öffnen Sie die Datei “gFM_Drucklayouts.gfm” in FileMaker Pro. Wechseln Sie über das Einblendmenü [Layout] in der Symbolleiste zu dem gewünschten Drucklayout, das Sie bearbeiten möchten. Sollte die Symbolleiste nicht angezeigt werden, können Sie diese in der Menüleiste unter [Ansicht > Symbolleiste] einblenden.

12.0.1 Dokumente bearbeiten und hinzufügen im Layoutmodus

Wenn Sie sich im gewünschten Layout befinden oder ein neues Dokument hinzufügen möchten, wählen Sie in der Menüleiste die Funktion Ansicht > Layoutmodus oder drücken Sie die Tastenkombination

<cmd> – <L> (Mac) oder <ctrl> – <L> (Windows)

1301-drucklayout-layoutmodus

Die Drucklayout-Datei befindet nun im Layoutmodus, und alle Layouts können von Ihnen bearbeitet werden. Den Layoutmodus erkennen Sie an den Symbolen und Schaltflächen in der FileMaker-Symbolleiste, deren Symbole sich im Vergleich zum Layoutmodus in Symbole geändert haben, die für die Bearbeitung im Layoutmodus erforderlich sind:

FileMaker Pro-Layouts legen das Erscheinungsbild der Daten fest, wenn sie angezeigt, gedruckt, zu einem Bericht zusammengefaßt, gesucht und eingegeben werden. Layouts werden gelegentlich „Berichte“ genannt, insbesondere in gedruckter Form.

In der Datei gFM_Drucklayouts.fmp12 können Sie beliebig viele Drucklayouts anlegen (z. B. Layouts für Korrespondenz, Statistiken, Listen, Flyer oder auch Adreßetiketten). Sie können ein Layout ändern, ohne Ihre Daten oder andere Layouts in der Datei zu beeinflussen. Layouts können bestimmte Felder enthalten und andere ausschließen. Wenn Sie die Daten in einem Feld ändern (im Blätternmodus), werden die Änderungen in diesem Feld für den gleichen Datensatz in allen Layouts der Datei reflektiert.

12.0.2 Erläuterung von Layouttypen

Die folgenden Abschnitte beschreiben jedes Layout, das Sie mit dem Assistenten für ein neues Layout erstellen können.

  • Liste, Bericht – Verwenden Sie ein Layout des Typs Liste, Bericht, wenn Sie mehrere Datensätze in Zeilen drucken lassen möchten (eine Liste mit Datensätzen). Mit Hilfe des Assistenten für neues Layout können Sie viele Varianten des Layouts Liste, Bericht definieren. Sie können ein Layout mit einfachen Datenzeilen und -spalten erstellen oder einen komplexen Bericht mit Daten, die nach angegebenen Werten mit Zwischen- und End- summen gruppiert sind. Ein Layout des Typs Liste, Bericht enthält die ausgewählten Felder in der angegebenen Reihenfolge von links nach rechts, mit Feldnamen als Spaltentiteln.
  • Formulare, Dokumente – Verwenden Sie ein Layout des Typs Formular, wenn Sie meh- rere Felder eines Datensatzes in einem Formular drucken möchten (z.B. Serienmailing, Kündigungsbestätigung, usw.). Formulare bestehen normalerweise aus einem Kopfteil, bei mehrseitigen Dokumenten zusätzlich Kopf 1. Seite, Datenteil und einem Fußteil.
  • Etiketten – Verwenden Sie ein Etikettenlayout, um Felder für den Druck auf einem der vordefinierten Standard-Etikettenformate anzuordnen. (FileMaker Pro stellt die Maße einer großen Anzahl von Standard-Etikettentypen zur Auswahl.) Wenn der gewünschte Etikettentyp nicht verfügbar ist, können Sie spe- zielle Etikettenmaße angeben.
  • Briefumschlag – Verwenden Sie ein Briefumschlag-Layout, um die gewählten Felder für den Druck auf einem Standardumschlag anzuordnen.

12.0.3 Duplizieren bestehender Drucklayouts

Im Drucksystem von gFM-Business befinden sich bereits viele Formular- und Listenansichten, deren Layout oftmals für eine neue Liste oder ein neues Dokument wiederverwendet werden kann. Es handelt sich dabei um verschiedenste Dokumente mit den Ursprungstabellen Kunden, Adressen, Angebotspositionen, usw. Um ein bestehendes Layout zu übernehmen, wählen Sie zunächst ein Drucklayout aus, das dem neu zu erstellenden Layout möglichst nahe kommt. Danach muß das Layout, dessen Elemente übernommen werden sollen, dupliziert werden (Layouts > Layout duplizieren). Das Drucklayout kann nun von Ihnen individuell benannt, angepaßt und bearbeitet werden.

  • Nachdem das Layout dupliziert wurde, müssen zunächst die Einstellungen für das neu erstellte Dokument getätigt werden. Der Dialog für die Layouteinstellungen wird im Menü unter Layouts > Layouteinstellung geöffnet.
  • Im Feld Layoutname geben Sie einen aussagekräftigen Namen für das neue Dokument an.
  • Im Popupmenü Datensätze anzeigen aus können Sie die Ursprungstabelle wählen, deren Datensätze auf dem Layout angezeigt werden sollen. Die Ursprungstabelle muß ebenfalls in den Einstellungen im Kapitel Drucklayouts eingetragen werden.
  • Unter der Registerschaltfläche [Ansichten] können Sie angeben, ob es sich um ein Formular handelt (Formularansicht) oder um eine Liste (Listenansicht) sowie eine Standardansicht auswählen.
  • Unter der Registerschaltfläche [Drucken] können Sie feste Seitenränder einstellen und den Spaltendruck aktivieren. Beim Spaltendruck wird Text, der sich in einem Textfeld befindet, automatisch in der angegebenen Spaltenzahl ausgegeben.
  • Mit Klick auf die Schaltfläche [OK] werden Ihre Einstellungen am aktuellen Drucklayout gespeichert.

12.0.4 Arbeiten mit Objekten in einem Layout

Ein Objekt ist ein einzelnes Element – ein Feld, ein Textobjekt, ein Grafikobjekt (z.B. eine Ellipse oder ein importiertes Bild) oder ein Ausschnitt – dessen Größe Sie ändern, das Sie auswählen, verlagern, löschen, kopieren, formatieren und auf andere Weise ändern können. Platzieren Sie Objekte in einem Layout, um dessen Gestaltung optisch zu verbessern. Sie verwenden für die Arbeit mit jedem Objekttyp spezielle Werkzeuge aus der Werkzeugpalette in der Statussymbolleiste (über Ansicht > Statussymbolleiste).

12.0.5 Auswählen von Objekten

Um mit einem Objekt in einem Layout zu arbeiten, müssen Sie es zunächst im Layoutmodus auswählen. Die Ecken des ausgewählten Objekts weisen kleine schwarze Quadrate, sogenannte Aktivpunkte, auf. Um ein Objekt auszuwählen, klicken Sie auf den Auswahlpfeil in der Werkzeugpalette. Der Zeiger nimmt die Form eines Pfeils an. Führen Sie dann eine der folgenden Aktionen aus:

  • Ein Objekt auswählen– Klicken Sie mit dem Mauspfeil auf das Objekt. Falls das Objekt transparent sein sollte, klicken Sie auf seine Begrenzung
  • Mehrere Objekte auswählen– Ziehen Sie einen Auswahlrahmen auf, der die Objekte einschließt oder halten Sie die Umschalttaste gedrückt, während Sie auf jedes Objekt einzeln klicken.
  • Alle Objekte auswählen– Menüleiste Bearbeiten > Alles auswählen
  • Alle Felder auswählen– Klicken Sie mit dem Mauspfeil auf ein Feld, halten Sie dann <Strg> gedrückt und wählen Sie im Menü Bearbeiten > Alles auswählen.
  • Einen Ausschnitt– Klicken Sie mit dem Mauspfeil auf die Begrenzung eines Ausschnitts oder einen anderen Bereich innerhalb des Ausschnitts, der kein Objekt enthält.
  • Deaktivieren ausgewählter Objekte– Klicken Sie in einen leeren Bereich des Layouts oder auf ein beliebiges Werkzeug in der Werkzeugpalette. Wenn mehrere Objekte aktiviert sind, drücken Sie während des Klickens die Umschalttaste.

Hinweis: Wenn die Aktivpunkte eines Objekts grau statt schwarz sind, ist das Objekt fixiert. Die Fixierung kann dann über das Kontextmenü der rechten Maustaste aufgehoben werden.

Detaillierte Einstellungen zu einem Objekt können Sie mit aktiviertem Layoutmodus im Inspektor vornehmen. Sollte der Inspektor nicht geöffnet sein, kann er in der Menüleiste unter [Ansicht > Inspektor] geöffnet werden.

12.0.6 Arbeiten mit Feldern in einem Layout

Nachdem Sie ein Layout erstellt haben, können Sie Felder hinzufügen, unerwünschte Felder entfernen und das Format festlegen, in dem die Daten angezeigt werden sollen. Felder in einem Layout sind Objekte, die Sie auswählen, verlagern, skalieren und umformen können. Im Layoutmodus zeigt jedes Feld seinen Feldnamen formatiert mit Attributen für Schriftart, Größe, Stil, Ausrichtung, Zeilenabstand und Farbe an. Alle Felder mit Ausnahme von Medienfeldern zeigen anhand von Grundlinien an, wo die Daten im Blätternmodus erscheinen und helfen Ihnen damit, die Felder miteinander auszurichten. Um die Standardformatierung, -erscheinungsbild und -verhalten eines neuen Felds festzulegen, wählen Sie die Optionen, ohne daß ein Feld ausgewählt ist. FileMaker Pro weist diese Standards allen Feldern zu, die später hinzugefügt werden.

12.0.7 Platzieren und Entfernen von Feldern in einem Layout

Sie können ein Feld an beliebiger Stelle und beliebig oft in einem Layout platzieren.

  • Wählen Sie im Layoutmodus das Layout, an dem Sie arbeiten wollen, aus dem Einblendmenü Layout in der Statussymbolleiste.
  • Ziehen Sie ein Feld vom Feldwerkzeug       mit gedrückter Maustaste an die gewünschte Position im Layout. Lassen Sie die Maustaste erst wieder los, wenn sich das Feld an der gewünschten Position befindet.
  • Wählen Sie im Dialogfeld Feld angebendas zu platzierende Feld aus.
  • Sie können ein Feld aus einer anderen Tabelle wählen, indem Sie die Tabelle aus der Tabellenliste über der Feldliste wählen. Wählen Sie dann ein Feld aus der Feldliste.
  • Wählen Sie Feldbeschriftung, um den Feldnamen automatisch als Text in das Layout aufzunehmen.
  • Klicken Sie auf die Schaltfläche [OK].

Der Feldname wird im Layout im entsprechenden Feld angezeigt, es sei denn, Sie haben die Anzeige von Beispieldaten aus dem aktuellen Datensatz aktiviert (Ansicht > Einblenden > Beispieldaten). Felder aus Bezugstabellen werden als Bezug::Feldname (mit zwei vorangestellten Doppelpunkten) angezeigt.

Um ein Feld durch ein anderes zu ersetzen, doppelklicken Sie im Layoutmodus auf das Feld, wählen Sie im Dialogfeld Feld angeben einen anderen Feldnamen aus und klicken Sie auf die Schaltfläche [OK].

Um ein Feld aus einem Layout zu entfernen, wählen Sie das Feld im Layoutmodus aus und drücken Sie dann die Rück- oder Löschtaste oder wählen Sie im Menü Bearbeiten > Löschen.